Conducted tests to assure the service is working well. Added mesures to avoid such issues in the future by conducting stress test close to midnight preferably in the weekends when there is less traffic.
Monitoring
Monitoring
Stopped testing process. Restarted the server and fixed the issue.
Identified
Identified
SMPP server received multiple request while testing uptime mechanism which caused CPU and RAM spike and cause server shutdown.